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Description

Haxial TextEdit is a simple, fast and free editor for Unicode plain text files 
(".txt" files).  It can also open non-Unicode plain text files.  It includes a 
Find/Replace function, and a menu for quick access to your favorite 
documents.

Note that plain text files do not support fancy formatting features or font 
styles etc, and thus neither does TextEdit because the purpose of TextEdit is 
only to edit PLAIN text files.

Features

• Supports the international Unicode standard.
• The program loads very quickly.
• Fast scrolling of very large files.
• Appearance of the user interface is highly customizable.
• Supports both soft and hard wrapping of text.
• Find and Replace features.
• Can count the number of occurrences of a piece of text in a file.
• Can alphabetically sort lines of text.
• "Favorites" menu allows quick access to your favorite documents.
• Rename a document from within TextEdit.

System Requirements

• MS Windows NT/2000/XP (does NOT work with 95/98/ME!)
• or MacOS X (10) or better, or MacOS 9 with CarbonLib 1.3.1+.

The Main TextEdit Window

When you open a text file with Haxial TextEdit, it looks like this:
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Across the top of the window is the menubar.  Click the menu titles to access 
the commands in that menu.   Below the menubar is a row of buttons, where 
each button represents a document / text file that you have open.  The 
highlighted button is the currently displayed document.  To display a different 
document, simply click its button.  You can also second-click (control-click if 
you have only 1 mouse button) on the buttons to show a context menu.  The 
rest of the window is simply editable text.  You can click and type into it to 
edit the text in the usual manner.

Some terminology for beginners:  If you single-click in editable text, a small 
vertical bar appears where you clicked.  This is called the “insertion point” 
because when you type, the characters are inserted at this point.  If you click 
and drag in editable text (press the mouse button, hold it down, move the 
mouse, then release the mouse button at a different location to where you 
pressed it), then all the text from the point where you pressed the button to 
the point where you released it is highlighted, as you can see in the above 
picture -- this is known as the “selection”.

The “File” Menu

New: Creates a new text editor document which you can 
begin typing into.  This does not create a file on 
disk until you Save it.

Open: Shows a window which allows you to select a file to 
open.  You can also drag & drop files into that 
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window.

Save: Any changes you make to the text are not saved on 
the disk until you use the Save command.  So this 
command causes the text to be written to disk.

Save As: Shows a window which allows you to save the text 
(including any changes) into a new file with a 
different name optionally in a different location.  
The text editor window then “becomes” this new 
file, and the previous file is no longer accessed.

Rename: Shows a window which allows you to enter a new 
name for this file.  If you proceed, the name of the 
file on disk and the editor window are changed to 
the name you entered.

Revert To Saved: Use this command if you wish to revert the 
document back to the last saved version, thus 
discarding any unsaved changes.  This is basically 
the same as closing the document without saving it, 
and then opening it again, but easier.

Move To Trash: Use this command when you want to delete the 
document.  It discards any unsaved changes to the 
document, closes it, and then moves the file to the 
Trash or Recycle Bin.

Soft Wrap Text: When on, this option causes lines of text to be 
“wrapped” to the width of the window, meaning 
that if a line of text would be wider than the width 
of the window, then it continues onto the next line.  
When off, if a line of text is wider than the 
window, then you need to use the horizontal scroll 
bar to see the rest of it, and text does not go onto 
the next line unless you specifically press the 
return/enter key.

Include Unicode Marker: This option controls whether the saved file will 
begin with a special unicode marker that identifies 
the format of the file as unicode text (UTF8), as 
opposed to the older/obsoleted text file formats or 
other unicode formats.  Normally you will want 
this on all the time in order to help with correct 
identification of the file format, however some 
older programs cannot handle the marker properly, 
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so for those cases you can turn it off to aid with 
compatibility.  For example, as of the time of 
writing, unix shell scripts will not work with the 
unicode marker.

MS Windows Line Endings: Normally Haxial uses unix-style line endings, 
whereas MS Windows uses a different method to 
denote lines (lines in this case meaning the 
character that is typed when you press the 
Enter/Return key).  You can turn this option on if 
you need compatibility with a program that only 
works with MS Windows line endings.  Haxial 
TextEdit can open text files in either format.

Settings: Shows the Settings window where you can set some 
options for TextEdit (explained further ahead in 
this documentation).

About: Shows the version number of TextEdit, and the 
address of the Haxial website.

Exit TextEdit: Exits/quits/closes the TextEdit program.

The “Tools” Menu

Find: Shows a window which allows you to find (and 
optionally replace) text in the file (explained 
further ahead in this documentation).

Find Next: Starting at the insertion point or selection, this 
finds the next occurrence of the text that is in the 
Find window.

Enter ‘Find’ Text: Puts the selected text into the Find window.
Replace & Find Next: After using “Find Next”, you might use this 

command to replace that text with the Replace text 
that is in the Find window, and then it finds the 
next occurrence.

Count: Shows a window with counts of 
characters/words/lines in the document and 
selection (explained further ahead in this 
documentation).

Sort Selected Lines: Reorders the selected lines of text so that they are 
sorted alphabetically.  Ascending is normal order 
(A to Z), and Descending is reverse order (Z to A).
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The “Favorites” Menu

The main TextEdit window contains a Menu Bar, and one of the menus is 
titled “Favorites”.  This menu gives you quick access to your favorite or 
“bookmarked” documents.  The menu shows the contents of a folder named 
“Favorites” in the same folder as the TextEdit program, thus you can 
configure the menu by placing shortcuts/aliases to your favorite documents 
into the Favorites folder.  Then they will appear in the menu, and you can 
click one to open it.  Note that you should NOT put your actual documents 
into the Favorites folder, rather you should use shortcuts/aliases.  You can 
also put shortcuts/aliases to folders into the Favorites folder, and TextEdit 
will open the folder when you click it in the menu.

The “Location” Menu

The main TextEdit window contains a Menu Bar, and one of the menus is 
titled “Location”.  This menu shows the location or path to the document.  In 
other words, it shows where the file is saved on your hard disk.  The first 
item is the name of the file, then the second item is the name of the folder 
which contains that file, then the third item is the name of the folder which 
contains that folder, and so forth.  Click a folder to open it.

The “Find and Replace” Window

The “Find and Replace” window is accessible from the Window Menu on the 
main window, and looks like this:

You type in what text you would like to find, and optionally some text to 
replace it.

Haxial TextEdit Documentation Page 5 of 11



Case Sensitive: If ticked, TextEdit will only find text in the file if 
the uppercase/lowercase of the letters exactly 
matches the Find text.  For example, normally a 
find for “uffish” would also find “Uffish” or 
“UFFISH”, but NOT if you tick “Case Sensitive”.

Stop at End of File: Normally, when TextEdit reaches the end of the 
file, it continues searching from the beginning of 
the file, ie the search wraps around.  But if you tick 
this option, then TextEdit will beep when it reaches 
the end of the file.

Find button: Starting at the insertion point or selection, this 
button selects the next occurrence of the Find text 
in the file window.  Which file does it affect if 
multiple are open?  The one that is ordered 
immediately below the “Find and Replace” window.

Cancel button: Hides the “Find and Replace” window.
Replace button: Finds the next occurrence of the Find text, and 

replaces it with the Replace text.
Replace All button: Replaces ALL occurrences of the Find text in the 

file with the Replace text, and then displays how 
many occurrences were replaced.

The “Count” Window

The “Count” window is accessible from the Window Menu on the main 
window, and looks like this:
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It shows the total number of characters (letters, digits, symbols, spaces etc) in 
the whole document, and in the selected text only.  It also shows the number 
of words, and the number of lines.  A hard line is defined as ending with a 
newline character (what the Enter/Return key types), or at the end of the text 
(the width of the window does not change this count).

Click the “Count” button to re-count the text (for example, if you change the 
text or the selection).

You can also count the number of occurrences of a certain piece of text.  
Type it into the text box, then click the “Count” button (or press the return 
key), and the count will be displayed in the “Custom:” line for the whole 
document and the selection.

The Settings Window

The Settings window is accessible from the Window Menu on the main 
window or the “File” menu.  The Settings window allows you to set a few 
options for TextEdit:

Editor Font: You can choose a different or smaller font to edit 
text with (font refers to the precise appearance of 
the individual characters in text).

Appearance: This lets you change the appearance of TextEdit to 
something that is more aesthetically pleasing to 
you.  Please see the other documentation file for 
more information about Appearances.
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Override Text Colors: If you tick this, you can control the color of the 
text in editor windows.  The Foreground color is 
the color of the text itself, where as the 
Background color is the color of the space 
“behind” the text.

Start TextEdit Hidden: This option is useful if you have your computer 
configured to automatically start TextEdit when 
the computer starts (because you want TextEdit 
running all the time).

MS Windows: If this option is ticked, TextEdit will minimize itself 
immediately after being opened/started.  You can restore it by 
clicking the TextEdit icon in the system tray (in the right 
bottom of the screen).

MacOS: If this option is ticked, TextEdit will hide itself immediately 
after being opened/started.  You can show it by bringing 
TextEdit to the front, as you would normally do for any Mac 
application.

Individually remember for each document: TextEdit can remember 
certain settings about each document individually.  
For example, if you turn on the “Scroll Position” 
option, then when you close and later reopen a 
document, it will be returned to the scroll position 
that it was at when you closed it.

Can I make MS Windows open all text files with Haxial TextEdit 
instead of Notepad?

Yes, you can configure Windows so that when a text file is double-clicked, it 
opens with Haxial TextEdit.

1. Click the Start Menu, then Settings, then Control Panel.
2. In the Control Panel, double-click “Folder Options” to open it.
3. Click the “File Types” tab.
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4. Find and select “TXT  Text Document” in the list.
5. Click the “Advanced” button.
6. Optional: Click “Change Icon” if you would like to change the icon to 

one inside Haxial TextEdit.
7. In the “Actions” list, double-click “open” to edit it.
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8. Click the “Browse” button to choose the copy of Haxial TextEdit that you 
would like to use.

9. Tick the “Use DDE” box.
10. Fill in the DDE boxes like this:

DDE Message:
"%1" (including the quotes)

Application:
TextEdit (actually this is the name of the 

executable file minus the “.exe”)
DDE Application Not Running:

(leave this box empty)
Topic:

System

11. Click the “OK” button etc to close the windows.
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Technical Description of Text Files in Haxial's Preferred Format 
(for Advanced Users Only)

There are many different variations in the format/encoding of plain text files.  
Unfortunately there is not 1 universal standard text file format being used by 
everyone.

The characters in a plain text file in the format that Haxial prefers are 
encoded using Unicode UTF-8.  Unicode is a successful international standard 
supporting every character in every Earth language.  Unicode can be encoded 
multiple different ways, and Haxial prefers the UTF-8 encoding, which has a 
high degree of compatibility with ASCII text, and no byte order ("endian") 
problems.

In UTF-8, ASCII characters are represented using a single byte (same as 
ASCII), and any other "extended" characters are represented using a sequence 
of 2 or more bytes (thus a character uses a variable number of bytes). UTF-8 
is favored in Unix environments (and on the Internet), and Haxial further 
embraces this by using Unix-style line-endings, meaning lines end with a 
linefeed/newline character (hex value 0A). For comparison, DOS/Windows 
unnecessarily uses 2 characters (carriage return followed by linefeed, hex 
values 0D and 0A).

That leaves us with the question of how to identify a Haxial text file and 
distinguish it from text files encoded using other methods. Haxial solves this 
by inserting a Unicode Byte-Order-Mark (BOM) character at the start of the 
file, which in UTF-8 is 3 bytes, EF BB BF (hex).  MS Windows Notepad also 
does this, so a text file beginning with EF BB BF is a UTF-8 file with either 
Unix/Haxial or DOS/Windows line endings, which are easily distinguished by 
searching for the first line ending.

So in summary, the Haxial preferred text file format is this:
Encoding: Unicode (UTF-8)
Line Endings: Unix-style (linefeed/newline) 0A
Identification Marker: Unicode BOM EF BB BF
Byte Order (“Endian”): Not applicable (8-bit)

Any questions/suggestions/feedback?

Your feedback and suggestions are welcomed.  Feel free to send a message to 
Haxial using the form on this webpage:
   http://www.haxialsoftware.com/contact/

--
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